Главная Компания Новости Корректирующие выпуски PostgreSQL: 9.4.3, 9.3.8, 9.2.12, 9.1.17 и 9.0.21

Корректирующие выпуски PostgreSQL: 9.4.3, 9.3.8, 9.2.12, 9.1.17 и 9.0.21

Разаработчиками PostgreSQL были представлены обновления для всех поддерживаемых веток данной СУБД.

На текущей неделе стали доступны для обновления корректирующие выпуски всех поддерживаемых веток PostgreSQL: 9.4.3, 9.3.8, 9.2.12, 9.1.17 и 9.0.21 с устранением ошибки в реализации механизма fsync.

Ошибка наблюдается в пакетах PostgreSQL 9.1 и 9.0 с SSL в Debian и Ubuntu.

Проблема касается конфигураций, имеющих в директории PGDATA дополнительные пользовательские файлы или директории отличные от "postgres".

В случае возникновения сбоя с загрузкой PostgreSQL, решением проблемы является временная смена прав доступа на недоступные на запись файлы в PGDATA на пользователя postgres.

Другие документы на эту тему

PostgreSQL

Описание СУБД PostgreSQL, инструментарий, инструкции и т.п.