качество и надёжность с 2008 года

8 (800) 200-25-11

Техническая поддержка support@komtet.ru —

круглосуточно и без выходных дней

load-whois

Онлайн-касса

для интернет-магазина

Подключите ваш интернет-магазин

к онлайн-кассе в соответствии с 54-ФЗ

 
Главная Техническая библиотека Фреймворки Zope Zope 2 Информация о релизе Zope 2.8.11

Информация о релизе Zope 2.8.11

Описание релиза python-фреймворка Zope 2.8.11.

Вы можете загрузить исходники и Windows-версию Zope 2.8.11:

http://www.zope.org/Products/Zope/2.8.11/

Некоторые новые возможности Zope 2.8

  • ZODB 3.4 с поддержкой MVCC (multi version concurrency control - многоверсионность и управление параллельными заданиями). MVCC решает почти все проблемы с ошибками конфликтов чтения в ZODB, что очень важно для высокопосещаемых Zope-сайтов;
  • Extension Classes (Классы расширения) переписаны как Python-классы в новом стиле (Python new-style classes), что сделало доступными все возможности Python-классов в Zope-объектах. Эти возможности также включают поддержку механизма циклической сборки мусора.
  • Интеграция с Zope 3 через Five (смотрите http://codespeak.net/z3/five/)

Вы можете сообщать об ошибках через трекер:

https://bugs.launchpad.net/zope2

Для более подробной информации о релизе Zope 2.8.11, обратитесь к:

http://www.zope.org/Products/Zope/2.8.11/CHANGES.txt

Смотрите так же http://www.zope.org/Wikis/DevSite/Projects/Zope2.8/OverView

Для получения подробной информации о доступных релизах Zope, руководстве по выору нужного дистрибутива и инструкциями по установке, обратитесь:

http://www.plope.com/Books/2_7Edition/InstallingZope.stx

Поддерживаемые версии Python

В настоящее время поддерживаются и рекомендуются только версии Python 2.3.4 и 2.3.5.

Использование Python 2.4.X не поддерживается и не рекомендуется. Python 2.4.X будет поддерживаться после проведения проверки безопасности. Это означает, что Вы используете Python 2.4 + Zope 2.8 на свой собственный риск. Это предупреждение также относится ко всем бинарным пакетам, которые устанавливаются при системной установке Python 2.4, например в Fedora, SuSE. Такие установки не поддерживаются. Кроме того, существуют некоторые сторонние продукты и Python пакеты, которые не работают с Python 2.4, и могут вызвать проблемы при использовании Python 2.4.

По материалам zope.org, перевод komtet.ru

Другие документы на эту тему

Скидка 30% на SSL-сертификаты!
Клиентам — домены в подарок!
Бесплатный тест виртуального хостинга
Перенос сайта — бесплатно
Все акции
На сайте КОМТЕТ используются cookie-файлы, данные о IP-адресе и местоположении посетителей. Если, прочитав это сообщение, вы остаетесь на нашем сайте, это означает, что вы не возражаете против использования этих технологий.